Add new comment

Al's picture

Hi Ark,

Unfortunately Ubuntu uses an old version of matplotlib (1.1.1~rc1) which causes this bug with certain graphics cards.

The only solution is to uninstall the Ubuntu version and install an up to date version from the matplotlib website (currently version 1.3.1).
On Ubuntu the installation is fairly simple, there are some instructions here, which I followed.  Please note that you should uninstall the previous version first by running:

sudo apt-get remove matplotlib