Add new comment

[email protected]:/usr/src/RTLSDR-Scanner/src# python rtlsdr_scan.py
File "rtlsdr_scan.py", line 39
print 'Import error: {}'.format(error)
^
SyntaxError: invalid syntax

Use gentoo linux. Have three versions of python installed:

[email protected]:/usr/src/RTLSDR-Scanner/src# eselect python list
Available Python interpreters, in order of preference:
[1] python3.5
[2] python3.4 (fallback)
[3] python2.7 (fallback)

I suspect that the syntax problem is a python version problem. If you concur is there a way to specify which version to use.

Also I just git cloned and there seems to be no installation needed. So I run it from the git clone dir.

Thanks,